A Custom Extension of Extended Time-Geographic Framework Tools in ArcGIS

Hongbo Yu¹ and Shih-Lung Shaw²

1 Department of Geography, Oklahoma State University, Stillwater, OK 74078 (hongbo.yu@okstate.edu)

2 Department of Geography, University of Tennessee, Knoxville, TN 37996 (sshow@utk.edu)

Release 1.0: August 24, 2009 (All rights reserved for the software and its documents)

Acknowledgement: This project is funded by the U.S. National Science Foundation Grant # BCS-0616724. Additional information about this NSF project is available at http://web.utk.edu/~sshow/NSF-Project-Website/default.htm.

Introduction

This extension is developed in support of an implementation of selected time geography concepts in a space-time GIS (2D space + 1D time) environment. This release of the extension includes several functions that generate space-time paths from appropriate input data sets (e.g., GPS tracking data, travel diary data) and facilitate interactive visualization of space-time paths in a space-time GIS environment.

Taking advantages of the existing 3D environment of ArcGIS, we developed custom program code to enable ArcScene (the 3D viewer of ArcGIS for spatial data) to represent a 3D space-time system of time geography and support the visualization of time geography objects (e.g., space-time paths, space-time prisms) in GIS. In this extension, the third spatial dimension (z) of ArcScene is used to represent the time dimension (t) in the space-time system of time geography.

Requirements

In order to use this extension on your computer, you need the following programs:

1. Microsoft .NET Framework 2.0 or above (available at Microsoft’s web site) installed on your computer; and
Installation

After you have downloaded the extension setup program (\texttt{STPathSetup.msi}) from our web site (\url{http://web.utk.edu/~sshaw/NSF-Project-Website}), double click the setup program to install the program on your computer. Follow the installation wizard to complete the installation. You may install the program to a specific folder on your computer. The default installation path is \texttt{C:\Program Files\TemporalGIS\STPath} (see Figure 1).

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{select-installation-folder.png}
\caption{Select installation folder for the program.}
\end{figure}

To uninstall the program from your computer, please use the “\textbf{Add or Remove Programs}” tool of Windows system to select the program and remove it from your computer (see Figure 2).

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{add-or-remove-programs.png}
\caption{Uninstall the program.}
\end{figure}
Custom Functions in the Extended Time-Geographic Framework Tools Extension

After you have installed this extension on your computer, you can enable the extension by choosing “Tools → Extensions...” from the main menu and check the box in front of “Extended Time-Geographic Framework Tools” in the Extensions window. Turn on the extension tools in ArcScene by choosing “View → Toolbars” and checking the item of “Extended Time-Geographic Framework Tools” in ArcScene. You will see a toolbar with the custom functions as shown in Figure 3 below.

![Custom toolbar](image)

**Figure 3. Custom toolbar of the Extended Time-Geographic Framework Tools Extension.**

These custom functions are developed to complete two tasks: 1) to create space-time paths from a compatible input data set; and 2) to facilitate interactive visualization of space-time paths in a 3D (2D space + 1D time) GIS environment.

### Create space-time paths

The **Create space-time paths button** in the custom toolbar is used to generate space-time paths from an input data set. The input data set can be a point feature class (e.g., GPS tracking log of a vehicle) or a polyline feature class (e.g., complete trip records derived from travel diary data). This function will find all tracking points or trips of an object, sort the records according to their temporal sequence, and connect them to generate a space-time path for the object.

Below are some notes for using this function:

1. In order to use this function to generate space-time paths, an input feature class must be added to the ArcScene.

2. The input data set can be a point feature class or a polyline feature class and the output feature class is a polyline feature class with z values. Both the input and output feature classes must be stored in a **personal geodatabase** (.mdb file).

3. The input feature class must have an appropriately defined **projected coordinate system**. The Geographic Coordinate System (i.e., longitude and latitude) may not work properly in this
extension. The projected coordinate system of input feature class is used to create the output space-time paths feature class.

4. Two fields (ID and timestamp fields) are required for a point input feature class to generate space-time paths, and three fields (ID, start time, and end time fields) are required for a polyline input feature class. The ID field contains the identity of a space-time path (e.g., the name of a person, an ID number assigned to a vehicle) and it can be in either String or Integer format. The timestamp field in a point input feature class records the time when the location information was collected. The start time and end time fields in a polyline feature class indicate the starting and ending time of each trip or movement. Two types of time formats are acceptable in this extension. A timestamp can be stored in either the Microsoft Date format (MM/DD/YYYY HH:MM:SS) or a numeric format (Integer or Float). See Figure 4 below for sample attribute tables.

![Attribute table of a point input feature class](image1)

![Attribute table of a polyline input feature class](image2)

Figure 4. Required fields in an input feature class to generate space-time paths
5. This function will not check the completeness or consistency of the input data set. For a point input feature class, this function will connect the tracking points according to their temporal sequence. For a polyline input feature class, this function assumes that the data set contains a complete set of trip records of each individual. In other words, we assume that the end location of a previous trip is the start location of the next trip in the data set. When generating space-time paths from these trips, this function simply connects the start/end locations of trips according to their temporal sequence. If there are missing tracking points or trips in the input feature class, this function will ignore the missing records and simply connect the previous record to the following record according to their temporal sequential order recorded in the input data set.

When you click the **Create Space-time Paths** button, a window will pop up (see Figure 5.) It asks you if you want to create a space-time path feature class from a point input layer or a polyline input layer. Different windows will show up in the next step depending on your choice.

![Wizard to Build Space-Time Paths](image)

**Figure 5.** Initial window to create space-time paths.

Figure 6 shows the dialog window to create space-time paths from a point feature class.

1. Select the point feature class that is used to generate space-time paths.

2. Select the space-time path ID field from a list (only those fields in Integer or String format are included in the list.)

3. Choose the correct time format according to the time stored in the input feature class.

4. Select the field holding timestamps for the tracking points.

5. Depending on your needs, you can make each space-time path have its own starting/ending time, which will be the minimum/maximum time recorded for the path in the input feature class. In this case, each path will have its own lifespan. You can also set all paths to have the same
6. You are provided with two choices to connect the tracking points. The first choice is to use tilted straight line to connect two temporally adjacent points (see Figure 7a). The second choice is to add an extra point between two adjacent points before connecting the points. The added point will have the identical spatial location as that of the previous point but the timestamp of the following point (see Figure 7b).

![Figure 6](image6.png)

**Figure 6.** Create space-time paths from a point feature class.

![Figure 7](image7.png)

**Figure 7.** Two choices of connecting tracking points.
7. Select the personal geodatabase to store the output space-time paths feature class. We recommend that you store the output feature class directly under the geodatabase level (i.e., as a standalone feature class).

8. Click the Save button to generate the space-time path feature class.

Figure 8 shows the window to create space-time paths from a polyline feature class. The settings are very similar to those in the window for creating paths from a point feature class. The major differences are: 1) you need to select two time fields (starting and ending time fields) instead of one; and 2) there is no choice for how to connect trips since there is only one way to connect them to generate paths.

Figure 8. Create space-time paths from a polyline feature class.
**Visualize space-time paths**

After you have created a space-time path feature class, you can add it and display it in ArcScene. The space-time paths are shown as 3D polyline features in ArcScene. The other functions in the Extended Time-Geographic Framework Tools toolbar are used to facilitate visualization of space-time paths in ArcScene.

We use background layers to locate time along the space-time paths (see Figure 9). These background layers can move up and down along the time dimension (i.e., z dimension in ArcScene). Using the custom functions in this toolbar, you can 1) set which layers are used as the background layers, the time format, and the time step for each up and down movement of the background layers; 2) move the background layers up or down along the time dimension based the chosen time step; and 3) move the background layers to a specific time location that you enter in the time box.

![Figure 9. 3D GIS visualization environment for space-time paths.](image-url)
You can set the parameters of the background layers by clicking the Layer Setting button. In the dialog window (see Figure 10), you can:

![Set layers to apply time changes dialog](image)

**Figure 10. Set parameters for background layers.**

1. Select layers to function as the background layers by checking the box in front of the layer name in the list.

2. Set the time format for the visualization environment. The selected time format will be used for time display in the time box of the extension toolbar. Make sure that the selected time format is the same as the time format of the space-time feature class to be visualized in ArcScene.

3. Set the time change interval and time unit for the movement of the background layers when the Up or Down button in the extension toolbar is clicked. When the Numeric time format is selected, the Time unit dropdown list will be changed to Unknown and disabled. When the MS Date time format is selected, you can choose from the following list - Year, Month, Week, Day, Hour, Minute, or Second. For example, if the MS Date time format is selected with the time interval set to 2 and the time unit set to Day, each click of the Up or Down button will move the background layers forward or backward by 2 days along the time dimension.
4. Click **OK** after you have chosen the settings for these parameters.

After you have set the display parameters, enter a time in the time box. Make sure that the time is in the correct format (for MS Date, the format is MM/DD/YYYY HH:MM:SS). Click the Refresh button to move the background layers to the time specified in the time box. The background layers will be displayed at the specified time point along the time dimension.

Click **Up** or **Down** button to move the background layers up or down along the time dimension by the specified time interval.

Since the time dimension often has a much smaller range than the (x,y) dimensions in a data set, you may want to change the **Vertical Exaggeration** property of ArcScene to exaggerate the z value to an appropriate scale such that the space-time paths can be better visualized in ArcScene display. The Vertical Exaggeration property can be accessed by clicking **View → Scene Properties**.
Sample Data Sets

You can download two sample data sets from our web site to test the Extended Time-Geographic Framework Tools Extension. After you unzip the downloaded file TGSampleDataSet.zip, you will get a TGSampleDataSet folder, which contains two personal geodatabase files: Migration-Sample.mdb and TravelDiary-Sample.mdb.

**Migration data set: a point input feature class case**

[Acknowledgement: This sample migration data set is derived from a subset of the survey data collected by the Survey Research Lab, Bureau of Business and Economic Research at The University of Montana – Missoula and funded by Congressional Appropriation secured by Sen. Byron Dorgan (North Dakota). The original migration data set was provided by Dr. Christiane von Reichert at The University of Montana.]

The Migration-Sample.mdb contains a migration dataset, which has three feature classes: CountyPoints, SampleRecords, and States. Follow the steps below to generate space-time paths from the migration tracking points.

1. Open ArcScene, turn on the Extended Time-Geographic Framework Tools Extension, and then add all three feature classes to the display.

2. Click the **Create Space-time Paths** button in the Extended Time-Geographic Framework Tools Extension toolbar.
3. In the pop up window, choose **Build space-time paths from point features** and click **Next**.

4. Set the parameters as shown in the following figure.

5. Click the **Save** button to save the output feature class in the Migration-Sample.mdb. [Note: If you change the default path and/or the default feature class name, the “Build Space-Time Paths from Point Features” dialog window will become hidden under your ArcScene display. Bring the
“Build Space-Time Paths from Point Features” dialog window to the front so you can click the **Save** button in the dialog window to save the output feature class.]

6. After the space-time path feature class is created, add it to the display.

7. Click the **Layer Setting** button to set the display parameters.

8. Set the parameters as shown below and click **OK**.

9. Enter 1950 to the **time box** in the extension toolbar and click the **Refresh** button.

10. Click the “View – Scene Properties” option in the main menu and change the **Vertical Exaggeration** to 50000. Click the **OK** button to close the Scene Properties window. Then, click the **Full Extent** button in the general **Tools** toolbar to show all layers. You should see the space-time paths as shown in the following figure. You now can move the background layers up or down by clicking the **Up** or **Down** button.
Travel diary data set: a polyline input feature class case

The TravelDiary-Sample.mdb contains a Tennessee dataset, which has two feature classes: AllTrips and Counties. The AllTrips feature class contains synthesized complete trip records of several individuals. Follow the steps below to generate space-time paths from the trip data.

1. Open ArcScene, turn on the Extended Time-Geographic Framework Tools Extension, and add both feature classes to the Scene.

2. Click the Create Space-time Paths button.
3. In the pop up window, choose **Build space-time paths from line features** and click **Next**.
4. Set the parameters as shown in the following figure. [Note: You must enter the data/time in the exact format as shown in the figure below. Do not leave out leading “0” in the hh:mm:ss format.]

5. Click the **Save** button to save the output feature class in the TravelDiary-Sample.mdb. [Note: If you change the default path and/or the default feature class name, the “Build Space-Time Paths from Point Features” dialog window will become hidden under your ArcScene display. Bring the “Build Space-Time Paths from Point Features” dialog window to the front so you can click the **Save** button in the dialog window to save the output feature class.]

6. After the space-time path feature class is created, add it to the Scene.
7. Click the Layer Setting button to set the display parameters.

8. Set the parameters as shown below and click OK. [Note: the “Time unit” box is enabled only after you have chosen the MS Date option for Time Format.]

9. Enter 10/16/2006 08:00:00 in the time box on the extension toolbar and click the Refresh button.

10. Click the “View – Scene Properties” option in the main menu and change the Vertical Exaggeration to 200000. Click the OK button to close the Scene Properties window. Then, click the Full Extent button in the general Tools toolbar to show all layers. Use the Zoom In button and the Navigate button in the general Tools toolbar to adjust the display, and you can get a display similar to the space-time paths as shown in the following figure. You now can move the background layers up or down by clicking the Up or Down button.