About ClickIt!

ClickIt! is really two programs in one. One program allows you to customize scanning and overlay access by creating Hot Spots. The other program allows you to enable each keystroke from the keyboard or IntelliKeys to speak out loud.

ClickIt! provides mouseless access for students who can’t use a mouse effectively. Persons with physical or visual disabilities can touch an overlay or switch to activate Hot Spots or operate a Windows computer with keyboard commands and speech feedback. Using the tutorial, you will create Hot Spots to make a software program accessible to overlay or switch users. You will also record a digitized scanning sound for each Hot Spot. Then you will create an IntelliKeys overlay to enable a user to access the software program using either an overlay or a switch. You will learn to create a WatchSpot, an innovative technology from IntelliTools, that assigns appropriate sets of Hot Spots to each screen of a program.

About this Tutorial

This tutorial uses an activity created with SimplePaint™, a painting program developed by IntelliTools. You will create Hot Spots to make this activity accessible to overlay or switch users. You will record digitized sounds for each Hot Spot and create two overlays to enable a user to access this activity using either IntelliKeys® or a switch. You will also create a WatchSpot™, an innovative technology from IntelliTools, which makes it easy to add Hot Spots to activities that have multiple pages (or screens).

IntelliTools has used ClickIt! to create a series of Instant Access Overlays for popular software programs from Edmark and Living Books. Using ClickIt! you can further customize these overlays to meet the needs of individual children.

Materials Needed

<table>
<thead>
<tr>
<th>TUTORIAL</th>
<th>Printed overlays: ClickIt! Automatic Scan, ClickIt! Directional Scan, ClickIt! Step Scan</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRINTED OVERLAYS</td>
<td>3 Standard ClickIt! Scanning overlays: ClickIt! Automatic Scan, ClickIt! Directional Scan, ClickIt! Step Scan</td>
</tr>
<tr>
<td>SOFTWARE</td>
<td>ClickIt! and ClickIt! Extra folder, Overlay Maker, Simple Paint</td>
</tr>
<tr>
<td>HARDWARE</td>
<td>IntelliKeys and cable, two switches (at least one, preferably two), and microphone for adding digitized sound to Hot Spots</td>
</tr>
</tbody>
</table>
Here are some samples of Instant Access Overlays that are available for purchase from IntelliTools:

Dr. Seuss’s ABC®

Three Living Books Access Options

Millie’s Math House®

Thinkin' Things® Collection I
SimplePaint

1. Get Ready to Make Hot Spots

You will use an activity created in SimplePaint™, an easy-to-use point-and-click paint program developed by IntelliTools. ClickIt! is already installed and running in the background on your machine.

- Open SimplePaint. Using your mouse, take a few minutes to become familiar with this paint program. After exploring, click on the eraser to erase the work you’ve done.

- Begin on the Animals screen. Press [Control]-[Space] to access ClickIt! You’ll notice a gray square in the center of the screen. It’s called a WatchSpot™ and will be discussed later in the tutorial.

- Click on the View menu. Deselect and select Show Watermark. Notice how this feature makes it easy to tell when you are working with ClickIt!.

2. Control-Click to Add Animal Hot Spots

Hot Spots mark locations on the screen where the user can click to operate the software program. The Hot Spots you create will have a keyboard equivalent keystroke, which makes these points accessible from a keyboard or IntelliKeys. On the “Animals” screen, you will start by creating Hot Spots for each animal.

- Hold down the [Control] key, and click the mouse on the elephant to create your first Hot Spot. The Hot Spot marker comes up as 1. Untitled. Rename it elephant.

  The order of your Hot Spots is important because ClickIt! scans numerically.

- Note that ClickIt! automatically defines a keystroke for each Hot Spot. In this case, the keystroke is Control-Shift-A. Click on OK. The new Hot Spot appears.

  Hint: The tip of the Hot Spot marker is the selection area of the screen and must be inside your object. You can adjust the position of the marker by clicking and dragging it. You can also move it by tapping the arrow keys on the standard keyboard.

  To delete a marker, click on it and press the Delete key.
Click on the elephant Hot Spot once to select it. Next, hold down the [Control] and [Shift] keys at the same time to view the highlight that the user sees when the Hot Spots are being scanned.

Change the highlight from an oval to a rectangle by holding down the [Control] and [Shift] keys and tapping the [Tab] key once.

To adjust the highlight area so that it surrounds the elephant, hold down the [Control] and [Shift] keys and tap the arrow keys on the keyboard.

*Hint:* Work carefully, the area within the highlight is captured and used later to create the keys for the overlay. For this reason you will want to make sure that the highlight is centered around the object.

Repeat the previous steps to create Hot Spots for the bear, the alligator, and the fox. Note that ClickIt! automatically assigns the keystroke content in alphabetical order. Control+Shift+B, Control+Shift+C, and so on. This sequence will continue as you create more Hot Spots.

*Hint:* The highlight will remain the same size and shape for each Hot Spot that you make, until you change the size.

Adjust the highlight size and shape so that it fits each animal.

3. Create Hot Spots for the Eraser and Colors

As with the animals, create a Hot Spot for the eraser. Rename the Hot Spot eraser.

Hold down the [Control] and [Shift] keys and carefully re-size the highlight using the arrow keys on the keyboard.

Create Hot Spots for the colors. Name them: red, green, gray, and brown.

At this time, you will not make a Hot Spot for the green page turn arrow.
4. Try Out Your Hot Spots from the Regular Keyboard

Each Hot Spot that you create assigns a keystroke to a specific location on the screen. By typing Control-Shift-A, for instance, you activate the elephant. Eventually, you will create an IntelliKeys overlay that employs these keystrokes. For now, you will enter the keystrokes manually to make sure they work.

- Press [Escape] to exit ClickIt!. The watermark disappears and you are now in SimplePaint. Try using the mouse to color in an animal to verify that you are in SimplePaint.

- Hold down the [Control] and [Shift] keys and tap the letter A to manually activate the elephant Hot Spot. Test all of your Hot Spots: Control-Shift-B (for the bear), Control-Shift-C (for the alligator), Control -Shift D (for the fox), etc.

5. Try Out Your Hot Spots for Scanners

You can observe how your Hot Spots will scan by selecting the [Control] and [Enter] keys. Eventually, you will use Overlay Maker to program switch access. For now, you will use keystrokes to see how scanning works.

- Hold down the [Control] key and press [Enter]. This will start an automatic scan of the Hot Spots you have made. Press [Control] and [Enter] again when you want to select a Hot Spot. Notice that each Hot Spot area is highlighted as you scan. While scanning you can adjust the speed by pressing a number from 1 (the slowest) to 9 (the fastest) from the numbers across the top of your computer’s keyboard.

6. Record Scanning and Selection Sounds

You can add recorded sounds to your Hot Spots to provide auditory reinforcement when the student scans or makes a selection. You will program the computer to say the name of each animal as it scans as well as identify the animal when it is selected.

- Hold down the [Control] and [Space] keys to access ClickIt!
- Double-click on the elephant Hot Spot. Click on the Sounds tab.
- To record a Scanning Sound, (what the computer says as it highlights each object), click on Record and say elephant. Then click on Stop. Click Play to listen to your sound. If you are satisfied, click Save.
- To record a Selection Sound, (the response the computer makes when an object is selected), click on Record and say This is the elephant. Be sure to Save your selection sound. Click on OK to close the dialog box.
- Record scanning and selection sounds for the bear, alligator, fox, eraser, and colors. Hit [Escape] and press [Control]-[Enter] to try out your scanning and selection sounds.
7. Try Out the Magnify Scanning Feature

ClickIt! can magnify the highlight area to make it more visible as you scan. This feature is designed to benefit people with visual impairments.

- Press [Control]-[Space] to bring up ClickIt! Choose the Options menu and select Magnify Scanning. Press [Escape] to exit ClickIt!
- Press [Control]-[Enter] to begin scanning. Notice how each Hot Spot area is magnified.
- To turn off the magnify feature, press [Control]-[Space] to enter ClickIt! Deselect Magnify Scanning and press [Escape] to exit ClickIt!

Creating an Overlay for the Animals Screen

In this important step, you will create an overlay for the SimplePaint Animals Screen. In order to do this, you must have Overlay Maker® from IntelliTools installed on your computer. Once you create an overlay, you'll be able to use this activity with IntelliKeys or a switch plugged into IntelliKeys.

You will make a nine key overlay that directly corresponds to your Hot Spots – one key for each Hot Spot. ClickIt! has been designed to easily interface with Overlay Maker. As you create a Hot Spot, ClickIt! automatically assigns a keystroke to it and captures a screen shot of the highlighted area. When you make an overlay, the screen shot and keystroke are automatically assigned to each key. This will enable you to complete your overlay in just a few minutes.

1. Making Your Overlay

The animal keys on the overlay should be just black and white. The student will select the colors. Therefore, all colors on the screen need to be erased before making the overlay.

- Click on the eraser to erase any colors on the screen.
- Press [Control]-[Space] to enter ClickIt! Click on the Overlays icon on the Toolbar.
- Click on the Edit tab.
- Choose the button labeled Make.
- In the Make Overlay dialog box, there are several choices. For this overlay, select All Hot Spots, Auto Scanning, and Pictures in Keys. Select OK.
2. **Name, Save and See Your Overlay**

   - Type in the File name *SimplePaint Animals Overlay* and select **Save**.

   Overlay Maker is automatically launched on your computer. An overlay is displayed with keys and graphics corresponding to each Hot Spot you created. If this does not occur, check to see that Overlay Maker is installed.

3. **Arranging the Keys on the Overlay**

   - Drag and resize the keys on the overlay to roughly match the picture on the right.
     
     *Note: The larger keys are 8x11 and the smaller keys on the left side are 5x4.*

   - Don’t forget to go under **File** and **Save** every few minutes as you work.

4. **Look at the Key Content…..It’s already there!**

   - Overlay Maker displays the content of each key in the lower left corner of the screen. To display key content, place the mouse pointer directly on top of each key on the overlay. Place the mouse pointer over the **elephant** key. Notice that the key content is Control-Shift-A Non-Repeating. When this key is pressed, the elephant is activated. Non-repeating has been automatically added to each key to prevent the key from repeating if held down by the user for a long time.

   - Go under the **Overlay** menu and look at the content for Switch 1 and Switch 2. Because you selected Auto Scanning when you made your overlay, [Control][Enter] appears as the switch content.

   - Go under the **File** menu and select **Save**. If you do not have a pre-printed copy of this overlay you will need to print the overlay at this time and then exit Overlay Maker. To exit Overlay Maker, go under **File** and select **Exit**.
5. Sending the Overlay Using ClickIt!

After you've completed your overlay and exited Overlay Maker, you will return to SimplePaint and send your overlay using ClickIt!.

• Return to SimplePaint. Press [Control]-[Space] to bring up ClickIt!.

• Select the Overlay icon.

• To send your overlay, choose the Send tab. Select the SimplePaint Animals Overlay and click on Select.

• Press [Escape] to exit ClickIt! The overlay will be ready to use with SimplePaint.

• Place your printed overlay on IntelliKeys and try it out.

• Use your switch in Switch 1 on the side of the IntelliKeys to automatically scan. Remember you can change the scan speed by pressing the numbers 1-9 on the keyboard.

The WatchSpot™: Using Hot Spots on Different Screens

This SimplePaint activity has two screens. Thus far, you made Hot Spots for the Animals screen. Now you're going to make Hot Spots for the Food screen. You will use an innovative technology called a WatchSpot to make sure that the appropriate sets of Hot Spots are assigned to each screen.

1. Reposition and Assign the First WatchSpot

• Press [Control]-[Space] to enter ClickIt!.

• Notice the small, gray, square on your screen. The area inside the gray frame is called the WatchSpot. When the screen changes, WatchSpot technology automatically changes sets of Hot Spots and overlay files.

  Note: The WatchSpot must be in the same location on every screen. It also must have an image unique to each individual screen of a program, such as numbers that change on the bottom of each screen.

• SimplePaint has a page number at the bottom of the screen that's an ideal location for the WatchSpot. Drag the WatchSpot so it covers the number at the bottom of the screen.
2. Make a New Set

The SimplePaint activity has a second screen called Foods. You will make a WatchSpot and a new set of Hot Spots for this screen.

- Click on the green page-turn arrow on the Animals screen to switch to the Food screen.
- Press [Control]-[Space]. Notice that the Hot Spots for the Animals screen are still there.
- Click on the Sets icon.
- Click on New. Name the new set Food.
- Under WatchSpot, click on Assign. Then click on OK. Notice that the WatchSpot image appears next to the name of the set.
- Click Done.

3. Make Three New Hot Spots for the Food Items

- Hold down the [Control] key, and click on the grapes to create a new Hot Spot. Rename it grapes. Notice that the keystroke defaults to Control-Shift-A. Adjust the highlight size and shape by using [Control]-[Shift] along with the Arrow and Tab keys.
- Create Hot Spots for the apple and the brownies. (You only need to create one Hot Spot to color both brownies).
4. Copy and Paste Hot Spots from the Animals Screen

- Instead of redoing the Hot Spots for the eraser and colors, you can copy the Hot Spots you’ve already created from the Animals screen. Press [Escape] to exit ClickIt! Go back to the Animals screen.

- Press [Control]-[Space] to re-enter ClickIt!.

- While holding down the [Shift] key, click on the Hot Spots for the eraser and each of the colors to select them all at once. Go under Edit and select Copy. This will copy the Hot Spots onto the computer’s Clipboard. Press [Escape].

- Return to the Food screen and enter ClickIt! by pressing [Control]-[Space]. Go under Edit and select Paste. Now your Hot Spots have been copied to the Food screen. Notice that the Hot Spots are automatically renumbered. When you are done, press [Escape].

- Scan the Hot Spots by pressing your switch or [Control]-[Enter] on the keyboard. Notice that your scanning and selection sounds for the eraser and the colors have been copied to the Food screen.

5. Try Dedicated Scanning

It is possible to scan using third-party switch interfaces. In this mode, the keyboard and/or mouse functions are used exclusively for scanning. Because these functions are dedicated to scanning, you cannot use the keyboard or the mouse until you exit Dedicated Scanning by pressing the [Esc] key.

- Press [Control]-[Delete] to open the Dedicated Scanning dialog box.

- Click to select Mouse. Press either your right or left mouse button to begin scanning. Remember you can change the scanning speed by selecting the numbers 1-9 from the standard keyboard.

- To exit Dedicated Scanning mode, simply press the Escape key [Esc].

Creating a Second Overlay

ClickIt! allows you to easily use different overlays with other screens within a software program. In this tutorial, you will create an overlay for the Food screen and attach that overlay to the Food Set. ClickIt! will automatically send the appropriate overlay to use as you alternate between the Animals and Food screens. This time you will make an overlay for students who need fewer choices by selecting only 6 of your 8 Hot Spots.
1. Select 6 Hot Spots for the Overlay

- Go to the Food page. Click on the eraser to erase all colors from the screen.
- Press [Control]-[Space] to enter ClickIt!
- Hold down the [Shift] key. At the same time, click on these 6 Hot Spots: grapes, apple, brownies, eraser, green and brown. Release the shift key.

2. A Keyguard Overlay in Less Than a Minute!

- Select the Overlays icon. Choose the Edit tab.
- Select Make. This will open the Make Overlay menu box.
- Choose Selected Hot Spots, Step Scanning, Pictures in Key, and Fit to Keyguard.
- Select OK.
- Name your overlay Food 6 Keys Overlay.
- The overlay is functional, accessible and complete! As you drag the mouse over each key you can see the Key Content in the lower left corner of the screen.
- Go to the File menu and select Save.
- Go back to the File menu and select Exit.

3. Attaching Overlays to Sets

You can attach overlays to the entire program using the Global Overlays feature, or have them available to specific sets. You will assign the SimplePaint Animals Overlay and the Food 6 Key Overlay to specific sets.

- Return to SimplePaint.
- Press [Control]-[Space] to enter ClickIt! Select the Overlays icon. Select the Edit tab.
- Click and Drag the SimplePaint Animals Overlay under the -Animals- heading. You may have to scroll down to see heading.
- Click and Drag the Food 6 Key Overlay under the -Food- heading. Select OK.
- Explore the Animals and Food screens with their customized overlays!
4. Selecting Specific Hot Spots to Scan

ClickIt! will automatically scan all the Hot Spots or you can limit the number of Hot Spots a switch user can access. You will modify the Food page to scan only six Hot Spots, and not scan ‘red’ or ‘brown’.

- Go to the Food screen and press **[Control]-[Space]** to bring up ClickIt!
- Double click on the red Hot Spot marker. Choose the Scan tab.
- Deselect the two items: **Include in Automatic Scan** and **Include in Directional Scan** as shown on the right. Click OK. Do the same for the gray Hot Spot marker. Press **Escape** to exit ClickIt!
- Try out your Hot Spots by pressing **[Control]-[Enter]**. You can also use two switches attached to the IntelliKeys. Switch 1 will automatically scan all Hot Spots. Switch 2 is used to make a selection.

Using Three Pre-Made Scanning Overlays

ClickIt! ships with three different scanning overlays that provide access to your Hot Spots. Each overlay represents a different type of scanning (automatic scan, step scan or directional scan), and can be used with IntelliKeys or switches plugged into IntelliKeys.

- Press **[Control]-[Space]** to bring up ClickIt!. Select the Overlays icon.
- Make sure you are in the Send menu. Three ClickIt! scanning overlays are listed. Select the ClickIt! Directional Scan overlay and click on Select.
- Put the appropriate overlay onto IntelliKeys® and use it with SimplePaint.
- Press **[Control]-[Space]** again and select the Overlays icon. Choose another overlay.
- It's possible to have several different overlays attached to an activity. You can switch back and forth to meet the needs of different students.
- If you select one of the Global Overlay items it will work throughout the entire activity.

Congratulations!

You have created two sets of Hot Spots, two overlays and a WatchSpot. You have attached both custom-made overlays and ClickIt!’s standard overlays to SimplePaint. You have made the program SimplePaint accessible without having to use the mouse. You can share ClickIt! creations with friends and colleagues even if they don’t own ClickIt!. Use the Make Installer feature located under the File Menu. You will be prompted to save your ClickIt! data and ClickIt! Player to disk(s) which can be installed on another windows computer.
Appendix

A. ClickIt!® Feature Highlight Sheet

B. Workshop Outline for the Trainer
Suggestions for incorporating the ClickIt! tutorial in a workshop format

Five-Pac and Multi-User Pricing Available.
Call 800-899-6687 for information.
Introduction to ClickIt!®

Feature Highlights

ClickIt! is two programs in one.
• Provides access to point and click software.
• Enables any letter/key typed to speak.

Access to mouse based software
• **Control-Space** will bring up ClickIt! Dialog box.
• Create a Hot Spot – a keyboard equivalent for any targeted point on the screen.
• Create a set of Hot Spots for each screen.
• Copy Hot Spots from one screen to another.
• Select a **WatchSpot™** image to correspond with each set of Hot Spots. ClickIt! will switch to the corresponding set of Hot Spots for each screen.

ClickIt! scanning features
• Scan Hot Spots in numerical order.
• Directional or Automatic scanning available.
• **Control-Enter** starts Automatic scanning.
• Record Selection sound for any Hot Spot.
• Record Scanning sound for a Hot Spot.
• Adjust Scanning Highlight color and size.
• Magnify Hot Spot (Options menu) will enlarge highlighted area.
• Use an asterisk to not include Hot Spot in scanning.
• Press **Escape** to exit Hot Spot menu.

Using the mouse and other keys as a switch
• Dedicating scanning option allows you to select the mouse or certain keys for Step and Automatic Scanning.
• Press **Control-Delete** to enable Dedicated Scanning.
• Press **Escape** to stop Dedicated Scanning.

Create an overlay to access Hot Spots
• Use ClickIt! to create an overlay.
• Decide which Hot Spots to use.
• Decide method of scanning.
• Utilize Fit to Keyguard option.
• Overlay Key will capture image within Highlight and label will be name of Hot Spot.
• The key content will be the keyboard equivalent to access the Hot Spot.

Attaching overlays to an application
• Attach an overlay to a set of Hot Spots or the entire application.
• Use **Control-Space** to access ClickIt! and send alternative overlays.
• Use ClickIt! **File** menu and create alternate sets of Hot Spots for the same application. You can also build an installer to transfer files to another computer.
• Go to the **ClickIt! File Menu** and select **Make Installer**. This will create installer disks to transfer your files to another Windows computer.
If you are using this tutorial as part of a workshop on ClickIt!, this section will help you prepare the materials and equipment you will need, as well as provide you with a suggested workshop outline to follow. Please feel free to duplicate the ClickIt! Tutorial and any of the files referred to in this tutorial for distribution at your trainings.

**CLICKIT! WORKSHOP OUTLINE**

**Introduction to ClickIt!** ................................ ................................ ................................ ........ 5 minutes

**Overview of Program**
- Provides mouse access for students who can’t use a mouse effectively.
- Offers two programs in one:
  1. One program provides access to point and click mouse-based software.
  2. The other program can enable each keystroke to speak out loud.

This workshop focuses on creating Hot Spots and overlays to access Hot Spots.

**Introduction to ClickIt! Tutorial** ................................ ................................ ....................... 2 1/2 hours
- Explore SimplePaint™ ................................ ................................ ....... 10 minutes
- Create Hot Spots ................................ ................................ ................ 30 minutes
- Create an overlay for a SimplePaint activity ........................ 20 minutes
- Create WatchSpot™ and second set of Hot Spots .................. 25 minutes
- Create second overlay ................................ ................................ ........ 15 minutes
- Explore Dedicated Scanning and other overlays .................... 20 minutes
- Explore the ClickIt! File menu and the Maker Installer Options...... 10 minutes

**Another way to use ClickIt!** ................................ ................................ ............................... 10 minutes
- Go to the Control Panel
- Locate ClickIt! Control Panel. Select Speak Letters. Return to any word processing program and begin to type.