Introduction to ClickIt!®
Macintosh Tutorial

About ClickIt!

ClickIt! provides mouseless access to point-and-click software for students who can’t use a mouse effectively. The program enables persons with physical or visual disabilities to touch an overlay or switch to activate Hot Spots or operate a Mac with keyboard commands and speech feedback.

ClickIt! is really two programs in one. The program can be used to customize scanning and overlay access by creating Hot Spots. The program can also be used to provide access to menus and dialogue boxes. It can also enable each keystroke from the keyboard or IntelliKeys® to be spoken out loud.

About this Tutorial

Using the tutorial, you will create Hot Spots to make a software program accessible to overlay or switch users. You will also record a digitized scanning sound for each Hot Spot. Then you will create an IntelliKeys® overlay to enable a user to access the software program using either an overlay or a switch. You will learn to create a WatchSpot™, an innovative technology from IntelliTools that assigns appropriate sets of Hot Spots to each screen of a program.

ClickIt! is available for Macintosh and Windows computers. Listed below are the materials needed to do this tutorial.

Materials Needed

<table>
<thead>
<tr>
<th>TUTORIAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to ClickIt! Tutorial</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PRINTED OVERLAYS</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 Standard ClickIt! Scanning overlays: ClickIt! Automatic Scan, ClickIt! Directional Scan ClickIt! Step Scan</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SOFTWARE</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClickIt!, Overlay Maker,® SimplePaint*</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>HARDWARE</th>
</tr>
</thead>
<tbody>
<tr>
<td>IntelliKeys and cable, two switches (at least one, preferably two), and microphone for adding digitized sound to Hot Spots</td>
</tr>
</tbody>
</table>

*Items with an (*) can be found on the web/tutorial CD-ROM available free from IntelliTools
Some examples of Instant Access Overlays that are available for purchase from IntelliTools:

**Dr. Seuss’s ABC®**

**Three Living Books Access Options**

**Millie’s Math House®**

**Thinkin' Things® Collection I**
Creating Hot Spots for SimplePaint™

1. Get Ready to Add Hot Spots!
   - Go under the **Apple** menu and select the Control Panel called **Keyboard**. Make sure **Delay Until Repeat** is not off. This will allow you more flexibility as you create your hot spots.
   - Open the **ClickIt! Extras** folder in your **IntelliTools® Workshop** folder. Open **SimplePaint™**. Become familiar with this program using the mouse.
   - Begin on the Animals screen. Press **Control-Space** to bring up the ClickIt! menu. Note the Application is identified as SimplePaint. Click on the **Hot Spots** icon.

2. Control-Click to Add Animal Hot Spots
   - Hold down the **Control** key, and click on the elephant to create a new Hot Spot. Hot Spots scan in alphabetical order. We will name these spots so they scan in order. Name the Hot Spot **a-elephant**.
   - Note the Keystroke defaults to Control-Shift-a. Click on **OK**, and the new Hot Spot appears. It’s that easy!
   - Hold down the **Option** key to view the highlight of a selected Hot Spot. Change the highlight from oval to rectangle by holding down the **Option** key and at the same time hitting the **Tab** key.
   - Change the size of the highlight by holding down the **Option** key and using the arrow keys on the keyboard. If necessary, reposition the Hot Spot using your mouse.
   - Create a Hot Spot for the bear. Change the name to **b-bear**. Note that the Keystroke must also change. The highlight size will stay the same size until you change it. Create Hot Spots **c-alligator**, **d-fox**.
3. Create Hot Spots for the Eraser and Colors
   • Create a Hot Spot for the eraser. Name the Hot Spot *e-eraser*. Click OK.
   • Hold down the Option key and re-size the highlight using the arrow keys on the keyboard.
   • Create Hot Spots for the colors. Name the Hot Spots: *f-red*, *g-green*, *h-gray* and *i-brown*.

4. Try Out Your Hot Spots from the Regular Keyboard
   • Press Escape to exit Hot Spots mode.
   • Hold down the Control and Shift keys and press the letter a at the same time to activate the elephant Hot Spot. Test all of your Hot Spots. Remember that the Keystroke Commands are alphabetical: Control-Shift-b (for the bear), Control-Shift-c (for the alligator) etc.

5. Try Out Your Hot Spots for Scanners
   • Now hold down the Control key and press Return. This will start an automatic scan of the Hot Spots you have made. Press Control-Return again to select the current Hot Spot. Notice that each Hot Spot area is highlighted as you scan.
   • Using ClickIt!® simply press a number on the keyboard from 1 to 9 to easily adjust the scanning speed while the student is working.

6. Record Scanning Sounds
   • Press Control-Space.
   • Click on the Hot Spots icon.
   • Double-click on the *a-elephant* Hot Spot.
   • Click on the Options button.
   • From the Sound pop-up menu, select Scanning Sound.
   • Click on Record, and record a scanning sound. You might say elephant.
   • Click Save and then click on OK to close all dialog boxes.
   • Record a scanning sound for the bear, alligator, fox and other Hot Spots on screen.
   • Hit Escape and press Control-Return to try out your scanning sounds.
Creating an Overlay for the Animals Page

Next, you will create an overlay to work with the SimplePaint™ activity using either an overlay or a switch. You will make nine keys that directly correspond to your Hot Spots—one for the elephant, one for the bear and so on.

1. Create the Overlay
   - Go to the Application menu in the upper right hand corner of your screen and select Hide SimplePaint.
   - Open up Overlay Maker® and get a new, blank overlay.
   - For this tutorial we will save the overlay on the Desktop. Name your overlay SimplePaint Animals Overlay. While you are working on the overlay, save at least every 10 minutes.

2. Create, Erase and Color Keys
   - Click to select the Key Tool.
   - Click and drag diagonally to create a key roughly the size of the key on the left side of the overlay. (5x4)
   - Go to the Edit menu and select Copy.
   - Go back to the Edit menu and select Paste four times. These keys will be for the eraser and the four colors.
   - Line up the keys like the picture on the right.

3. Create and Label the Animal Keys
   - Create and drag diagonally to create a key roughly the size of the larger keys on the overlay. (8x11)
   - Go to the Edit menu and select Copy.
   - Go back to the Edit menu and select Paste three times. These keys will be for the animals.
   - Move the keys to match the printed overlay.
   - Select the Text Tool and label each of the keys on the overlay appropriately.
4. Add Pictures and Color to the Keys

- Click to select the **Pointer Tool**
- Select **Picture Library** from the **Edit** menu.
- Select the **Elephant** picture, and click on **Black and White**. Then click on **Copy**.

- Paste the picture onto the appropriate key.
- Add the Bear, Alligator, and Fox pictures to the appropriate keys.
- Select colors from the **Fill Tool**

![Fill Tool](image)

...to color the keys red, green, gray and brown.

5. Add Content to the Keys

- Double-click on the key containing the elephant. The **Edit Content** dialog box will appear. Select **Show Special** and make sure **Keyboard Keys** is selected.
- Add `[Control][Shift]a` as the key's content.
- Go to **Other** and add **Non-Repeating**. Non-Repeating will prevent the key from repeating over and over if held down too long by the student.
- Edit the content of the other keys.
  - The bear should contain `[Control][Shift]b[Non-Repeating]`
  - The alligator should contain `[Control][Shift]c[Non-Repeating]`
- Continue to put the key content in the other keys on the overlay.

(Hint—quickly tap two times on the control key on your keyboard to enter a [control] in the Key Content box. Tap the shift key two times to add [shift] to the Key Content.)
6. Set the Switch 1 Content for Scanning

IntelliKeys® has two switch ports. The Hot Spots in ClickIt!® will scan alphabetically when the student presses a switch. One way to initiate scanning is with Control-Return. We will put Control-Return as the key content for Switch 1.

- Select the Overlay menu on the Menu Bar.
- Select Switch 1.
- Select Show Special.
- Go to the Special Characters menu. Select Keyboard Keys.
- Select Control and click Add Special.
- Select Return and click Add Special. Click on OK.

7. Save and Send the Overlay

- From the File menu, select Save.
- From the File menu, select Send Overlay. The overlay will be sent to IntelliKeys.

8. Test the Overlay

- Go to the Applications menu in the upper right hand corner of your screen and select SimplePaint™. You should be on the Animals page.
- Slide the printed overlay into IntelliKeys.
- Press keys on the overlay and color in the animals.
- Try your switch in Switch 1 on the side of the IntelliKeys.
The WatchSpot™: Using Hot Spots on Different Screens

SimplePaint™ has two screens. Thus far, we have made Hot Spots for the Animals screen. Now you are going to make Hot Spots for the Food screen. You will use an innovative technology called a WatchSpot to insure that the appropriate sets of Hot Spots are assigned to each screen.

1. Reposition and Assign the First WatchSpot

- Press Control-Space.
- Click on the Sets icon.
- Select Rename and change the name of the Main Set to Animals. Click on OK. This will help you to know the name of the set for the current screen.
- Click on Reposition.
- Drag the WatchSpot to a new location so that it is covering the SimplePaint page number at the bottom of the screen. Press Escape to return to the Sets dialog box.
- Under WatchSpot click on Assign to Set. The WatchSpot image will appear next to the name of the set.
- Click on Done to close this dialog box.

2. Make a New Set

Now we will make a WatchSpot for another set of Hot Spots on another screen. After we create the next WatchSpot we can then assign the Hot Spots.

- Click on the green arrow on the Animals screen to switch to the Food screen.
- Press Control-Space.
- Click on the Sets icon.
- Click on New. Name the new set Food. Click on OK.
- Under WatchSpot click on Assign to Set. Notice that the WatchSpot image appears next to the name of the set.
- The WatchSpot needs to be in a location that is unique to an individual screen. Because this program has page numbers on the bottom of the screen, the WatchSpot is already positioned.
- Click Done.
3. Make New Hot Spots for the Food Page

- Select Yes to enter Hot Spots mode. You are ready to make new Hot Spots.
- Hold down the Control key, and click on the broccoli to create a new Hot Spot. Name it a-broccoli.
- Notice that the Keystroke defaults to Control-Shift-a. We will not change the Keystroke at this time.
- Size the highlight using the Option and Arrow keys.
- Create Hot Spots for the apple and peanuts. (You only need to create a hot spot for one of the peanuts. When you click on it the others will also be colored in).
- Create a Hot Spot for the eraser. Resize the highlight. Now, create Hot Spots for the colors. When you are done editing, press Escape.
- Scan the Hot Spots by pressing your switch or Control-Return on the keyboard.

4. Use ClickIt!® to Attach Overlays to SimplePaint™

Instead of designing an overlay specific to the food page, you will use the scanning overlays that come with the ClickIt! program.

- Press Control-Space to bring up the ClickIt! menu. Click on the Overlays icon. Now select Attach.
- Locate and open the IntelliTools® Workshop folder on your desktop. Open the ClickIt! Extras folder. Open the Scanning Overlays-IntelliKeys® folder. Select the ClickIt! Automatic Scan and click Attach. Select Attach again to add ClickIt! Directional Scan and then add ClickIt! Step Scan.
- Select the ClickIt! Directional Scan overlay and click on Send.
- Put the respective overlay on the IntelliKeys® and use it with SimplePaint™
- Press Control-Space again and the Overlay icon. Choose another overlay. It's possible to attach several different overlays to an activity and switch back and forth as needed.
- You can even attach the SimplePaint Animals Overlay that you created earlier.
Appendix

A. ClickIt!® Feature Highlight Sheet

B. Workshop Outline for the Trainer
   Suggestions for incorporating the ClickIt! tutorial in a workshop format

C. Create Your Own Hot Spots for Thinkin’ Things
   If you own the Thinkin’ Things Collection 1 program by Edmark, you can use this mini-tutorial to create your own Hot Spots

Five-Pac and Multi-User Pricing Available.
Call 800-899-6687 for information.
ClickIt! provides access for students who can’t use a mouse effectively.

ClickIt! is two programs in one
- One program provides mouseless access to menus, dialog boxes, windows and scroll bars.
- One program provides access to point and click mouse-based software.

Access to menus and dialog boxes

ClickIt! Features
- Scan any Hot Spot you create.
- Directional or Automatic Scanning available.
- Control-Return starts Automatic Scanning.
- Record Selection sound for any Hot Spot.
- Record Scanning sound for any Hot Spot.
- Adjust Scanning Highlight size.
- Attach Overlays to applications.

Using the mouse and other keys as a switch
- Dedicated Scanning option allows you to select the mouse or certain keys for Step and Automatic Scanning (Control-Delete)

Help Menu
- CONTROL ? brings up the Keyboard Summary of ClickIt! commands. See below:

ClickIt! is found in the Control Panel
- Each underline appears below a unique letter that can be used with the selected modifier key—in this case Control. For example: Control-H would access the Help button in the box above.
- Select Speak Menus to hear all menus and contents read to you as you use ClickIt!
- Any highlighted text, file and folder name can be made to speak: CONTROL’ (single quote)

Access to Mouse Based Software
- Control-Space will bring up ClickIt! Dialog Box
- Create a Hot Spot—a keyboard equivalent for any targeted point on the screen
- Create a set of Hot Spots for each screen
- Select a WatchSpot™ image to correspond with each set of Hot Spots. ClickIt! will switch to the corresponding set of Hot Spots for each screen.

ClickIt! Data files can be located inside the system folder. They are stored in the Preferences folder inside the ClickIt! Files folder. Each file is name the same as the application, plus the extension “.it!”
Introduction to ClickIt!®
Workshop Outline for the Trainer

Estimated time: 3 hours

If you are using this tutorial as part of a workshop on ClickIt!, this section will help you prepare the materials and equipment you will need as well as provide you with a suggested workshop outline to follow. Please feel free to duplicate the ClickIt! tutorial and any of the files referred to in the tutorial, for distribution at your trainings.

**MATERIALS NEEDED**

- Make sure the following software is installed on each computer: ClickIt!, Overlay Maker,® and Simple Paint.® [Optional: Edmark’s Thinkin’ Things]
- Print one set of overlays for each computer prior to the workshop. Include the ClickIt! Standard Overlays, and the Simple Paint Animals Overlay, [Optional: Oranga Overlay]. (Instructions for making the Simple Paint Animals Overlay and the Oranga Overlay are included in this tutorial.)
- If computers are equipped with CD-ROM drives, you can demonstrate any of the Living Books® from Brøderbund®. You will need the Brøderbund software as well as the appropriate Instant Access to Living Books Software set from IntelliTools.
- Each participant should bring two blank, formatted disks for copying IntelliTools Training Materials files as well as any activities made during the workshop.

**CLICKIT!® TUTORIAL OUTLINE**

**Introduction to ClickIt!** ....................................................... 5 minutes

**Overview of Program**

- Provides mouse access for students who can’t use a mouse effectively.
- Offers two programs in one:
  1. One program provides access to point and click mouse-based software.
  2. The other program provides access to menus and dialog boxes.

This workshop focuses on creating Hot Spots and overlays to access Hot Spots.

**Living Books® (Optional)** .................................................... 20 minutes

- Show Just Grandma and Me® CD (or another Living Books® CD of your choice) using first a mouse and then an Instant Access overlay. Show Hot Spots.
- If equipment is available, let participants explore Living Books CDs at their own computer or at stations equipped with CD-ROM drives.
Introduction to ClickIt! Tutorial ............................................. 2 1/2 hours

- Explore SimplePaint ..................................................... 10 minutes
- Create Hot Spots ........................................................ 30 minutes
- Create an overlay for a SimplePaint activity ...................... 40 minutes
- Create sets and the WatchSpot™ ................................... 25 minutes
- Attach standard ClickIt! overlays ................................... 15 minutes

[Optional]
- Creating your own Hot Spots for Thinkin’ Things® ............ 30 minutes

Another way to use ClickIt! .................................................. 5 minutes

- Point out the lines under the Menus and File Names.
- Demo and have participants hold down the Control key and press the F key.
- Use the up and down arrow keys to scroll down the pull-down menus. Use the return key to select an item.
- Mention that this is useful for people who use the computer with just one finger and who can’t take their hands off the keyboard to use a mouse.
Creating Your Own Hot Spots for Thinkin' Things®

1. Create Hot Spots™

You will now create your own Hot Spots and overlay for Thinkin' Things® from Edmark®. After you create the Hot Spots you will take a screen shot and cut and paste the graphics to be used on your overlay.

- Open Thinkin' Things and select Oranga.
- Create Hot Spots for each instrument. Size the highlight and note the keystroke.
- Practice scanning your Hot Spots.

2. Take a Picture of the Screen

- Now you will create a pict file to be used as clip art for your overlay.
- Hold down the Command and Shift key and press the number 3. This will create a pict file of the Oranga screen. This file will be saved as Picture 1 on your hard drive.
- Quit Thinkin' Things.

3. Create the Overlay

- Create an overlay with 8 blank keys to match the one pictured on the right.
- Open the file labeled Picture 1 on your hard drive. It should open as a Simple Text file.
- Click and drag to select the chimes and copy them onto the clipboard. Paste this graphic onto the first key.
- Go back to the Picture file and copy and paste each instrument onto the overlay.
- Complete the Key Content of each key to finish the overlay.
- Save the overlay and send it to IntelliKeys®. Open Thinkin' Things and try your new overlay.

4. Locate the Hot Spots Preference File

- The ClickIt! Hot Spots file you just created is named Thinkin’ Things.It! and it is found in the ClickIt!® Files folder in the Preferences folder within the System Folder.